Tag Archives: Problems

Hmm this is new

Well now this is something new that the car has decided to do.

The MyFord Touch system has had a very rocky history. Many people can’t stand it (with good reason), some people like it (I’m one of them). Regardless of where you stand it can get maddening from time to time when it doesn’t exactly work.

Recently the MFT in my FFE has started acting up. For some reason it just decides that I shouldn’t be listening to the radio so it shuts it off on me. It behaves exactly like I hit the power button: The display switches to the power off screen showing the button and the audio cuts out. I can hit the power button to turn it back on again but sure enough within a couple of minutes it shuts off again. So far in the 4 vehicles we have had with MFT we’ve never seen this kind of behavior.

To try to rectify the situation I’ve attempted:

  • Pulling fuse 67 (the sync module/MFT fuse) to reset it
  • Performed the master reset
  • Tried out every audio source to make sure it isn’t isolated to one

So far nothing has worked (switching to FM seemed to work but sure enough after about 10 minutes–long enough to make me think that it might work–it shut off). Sigh..I may now have my first issue with the car that I have to take it in for service… oh joy.

This doesn’t appear to be a mechanical thing like a loose wire: It has happened at stoplights when the car wasn’t moving, and it only turns off the radio (if there was a loose wire in the power button I’d expect it to also power the radio on when it is off).

Update: Radio heal thyself. From what I’ve heard the issue was with a local radio station’s HD equipment and affected quite a few vehicles. They have apparently fixed their broadcast equipment. So no trips to the dealer for me.